I found the rattle

Post Reply
mooreken
Posts: 178
Joined: Sat May 09, 2015 12:25 pm

I found the rattle

Post by mooreken » Tue Oct 02, 2018 6:13 pm

I had a large rattle after the track day at Daytona.
It didn’t take long to find. The harmonic balancers rubber insert gave up and the outer ring became unattached. The alternator pulley stopped the ring from flying off. Glad I decided to cut the last session short.
4D0E13F1-81E9-4AA7-AF93-6059EC126E4A.jpeg
4D0E13F1-81E9-4AA7-AF93-6059EC126E4A.jpeg (2.13 MiB) Viewed 141 times
I had an oil leak along with a slightly lower oil pressure reading as I’m going to upgrade to a road race pan I pulled the circle track pan off. So far things look ok. I’ll pop a couple rod bearings and take a look. I think the lower pressure was the pan gasket breaking up a little. Don’t know why it was a good brand.
I cut the filter apart and found a fair amount of 1/8 to 3/16” chunks in the filter. Hopefully that was the pressure issue.

Avalanche325
Posts: 44
Joined: Wed Jul 22, 2015 6:06 pm

Re: I found the rattle

Post by Avalanche325 » Wed Oct 10, 2018 5:28 pm

Look at SFI rated balancers. They are rated for high RPM and if they fail, won't throw the outer ring through your hood.

mooreken
Posts: 178
Joined: Sat May 09, 2015 12:25 pm

Re: I found the rattle

Post by mooreken » Wed Oct 10, 2018 6:03 pm

Thanks...that is what I have replaced it with. This was the second failure I had with this brand in the last 6 months. The first one only slipped. Made the timing lines go all wacky.

Post Reply